通达信主图叠加BOLL-M公式代码
侧边栏壁纸
  • 累计撰写 47 篇文章
  • 累计收到 3 条评论

通达信主图叠加BOLL-M公式代码

demofree
2023-03-04 / 0 评论 / 130 阅读 / 正在检测是否收录...

  通达信主图叠加BOLL指标和副图叠加BOLL指标是不一样的,副图叠加为其它软件通用的,主图叠加代码如下:

{参数 N: 2 250 20}

MID:=MA(C,N);
VART1:=POW((C-MID),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPER:=MID+2*VART3;
LOWER:=MID-2*VART3;
BOLL:REF(MID,1),COLORFFFFFF;
UB:REF(UPPER,1),COLOR00FFFF;
LB:REF(LOWER,1),COLORFF00FF;

  如要布林线中轨上升或下降时显示不同的颜色,可再加入以下代码:

上升:IF(BOLL>REF(BOLL,1),BOLL,DRAWNULL),COLORRED,LINETHICK1;
下降:IF(BOLL<REF(BOLL,1),BOLL,DRAWNULL),COLORGREEN,LINETHICK1;
0

评论

博主关闭了当前页面的评论