demofree

通达信主图叠加BOLL-M公式代码
  通达信主图叠加BOLL指标和副图叠加BOLL指标是不一样的,副图叠加为其它软件通用的,主图叠加代码如下: {参...
扫描右侧二维码阅读全文
06
2017/11

通达信主图叠加BOLL-M公式代码

  通达信主图叠加BOLL指标和副图叠加BOLL指标是不一样的,副图叠加为其它软件通用的,主图叠加代码如下:

{参数 N: 2 250 20}

MID:=MA(C,N);
VART1:=POW((C-MID),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPER:=MID+2*VART3;
LOWER:=MID-2*VART3;
BOLL:REF(MID,1),COLORFFFFFF;
UB:REF(UPPER,1),COLOR00FFFF;
LB:REF(LOWER,1),COLORFF00FF;

  如要布林线中轨上升或下降时显示不同的颜色,可再加入以下代码:

上升:IF(BOLL>REF(BOLL,1),BOLL,DRAWNULL),COLORRED,LINETHICK1;
下降:IF(BOLL<REF(BOLL,1),BOLL,DRAWNULL),COLORGREEN,LINETHICK1;
最后修改:2017 年 11 月 06 日 02 : 57 PM
如果觉得我的文章对你有用,请随意赞赏

发表评论